Results 1 to 6 of 6

Thread: Mount Glitches

  1. #1

    Mount Glitches

    Just wondering if anyone else has come across the glitch where they are unable to dismount from one mount to ride another, atm only have two mounts leopard and rhino, both however say 'ride' there no option to 'rest' my leopard in favour of riding my rhino. Have tried refreshing/clearing cache or even another browser to no avail.

    Sad to see my Leo go, we have a many good battle together, but he just doesn't cut it anymore. He did get an lease on life for about two months so he can't complain

    If this has been already discussed, point me in it's direction, i apologize for starting a new thread on it, just was unable to find one pertaining to this particular problem.

    Ty for any replies.

  2. #2
    Judgment Revan's Avatar
    Join Date
    May 2013
    Posts
    1,512
    Haven't heard of this one. Did you try using the support tab near the chatbox in-game. Maybe send some screenshots with the ticket.
    "Revan. It isn't my real name—never was—but it will do."

    "Alderaan. They're on Alderaan."

    "Fat people always lie."

    "Honor is a fool's prize. Glory is of no use to the dead."

  3. #3
    Forum Moderator Morgan le Fay's Avatar
    Join Date
    May 2013
    Location
    Clarity
    Posts
    2,023
    Send in a support ticket as Revan has suggested. However, have you tried to click 'Ride' on your Rhino? If you are on a mount, clear out the cache and refresh as it could be a display bug.

    It's possible that you are not on either mount at moment. Stranger things have happened in this game, lets hope it's a simple fix for you.

    Forum Moderators are volunteers and are unable to fix in game problems

  4. #4
    have sent in a few support tickets, just get the same reply they are looking into it, after two moths thought maybe would have some kind of answer, have clicked ride and cleared cache (along with refreshing right after) numerous times to no avail, doubtful its a display bug, when i upgraded the rhino's star level i did not get the boost.

    also tyvm for quick replies
    Last edited by tynongame_6594602; 05-28-2014 at 12:33 PM.

  5. #5
    it's been fixed, woohoo. can close this thread if you want.

  6. #6
    Forum Moderator Morgan le Fay's Avatar
    Join Date
    May 2013
    Location
    Clarity
    Posts
    2,023
    Quote Originally Posted by tynongame_6594602 View Post
    it's been fixed, woohoo. can close this thread if you want.
    Pleased to see that

    Closed on request.

    Forum Moderators are volunteers and are unable to fix in game problems

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •